Triángulo de Floyd

De Wikipedia, la enciclopedia libre
Saltar a: navegación, búsqueda

El Triángulo de Floyd, llamado así en honor a Robert Floyd, es un triángulo rectángulo formado con números naturales. Para crear un triángulo de Floyd, se comienza con un 1 en la esquina superior izquierda, y se continúa escribiendo la secuencia de los números naturales de manera que cada línea contenga un número más que la anterior:

1
2 3
4 5 6
7 8 9 10
11 12 13 14 15

Una de los ejercicios más comunes en los cursos de introducción a la programación de ordenadores consiste en escribir un pequeño programa que produzca este triángulo.[1] [2] El triángulo de Floyd tiene varias propiedades matemáticas interesantes. Los números del cateto de la parte izquierda forman la secuencia de los números poligonales centrales, mientras que los de la hipotenusa nos dan el conjunto de los números triangulares. La suma de los números de la línea n equivale a n(n2 + 1)/2 (sucesión A006003 en OEIS).

Algoritmo computacional[editar]

En PSeInt es:

	Definir TAMANIO Como Entero; 
	TAMANIO <- 10;
	Definir i, j, t Como Enteros;
	t <- 1;
	Escribir "Triángulo Floyd";
	Para i <- 1 Hasta TAMANIO Con Paso 1 Hacer
		Para j <- t Hasta t + i - 1 Con Paso 1 Hacer
			Escribir j, " " Sin Bajar;
		FinPara
		Escribir "";
		t <- t + i;
	FinPara
FinProceso

En Java es:

public class TrianguloFloyd {
public static void main(String[] args) {
       final int TAMANO = 10;
       int t = 1;
       System.out.println("\nTriángulo Floyd\n");
                for (int i = 1; i <= TAMANO; ++i) {
                     for (int j = t; j <= t + i - 1; ++j) {
                          System.out.print(j + "\t");
                     }
                System.out.println("\n");
                t += i;
                }
       }
}

Véase también[editar]

Referencias[editar]

  1. Keller, Arthur M. (1982), A first course in computer programming using PASCAL, McGraw-Hill, p. 39 .
  2. Peters, James F. (1986), Pascal with program design, Holt, Rinehart and Winston, pp. 137, 154 .